NSLU2-Linux
view · edit · print · history

The NSLU2 is shipped with different power supplies in different parts of the world. Some people outside the US buy their slugs from amazon.com and source their own power supplies locally. The slug takes a regulated 5V at 2A; the center pin of the supply socket is the positive line. Any regulated PSU which supplies 1.5A or more with the correct plug size will do (2.5mm *** noteA). They are widely available and can be purchased from your local electronics supply store. Do not use an unregulated supply; the voltage peaks they generate can damage the power supply switching components.

It has been noticed that the supplied Linksys PSU appears to fail after about a year if supplying two USB powered 2.5" laptop drives from the NSLU2.Symptoms include, but not limited to hard drives not being mounted properly at boot time, although the slug will boot with no disks attached for a while until the supply dies completely. If you can only source a suitable replacement power supply with a 2.1mm power plug output then an adaptor is required to convert to the NSLU2 2.5mm plug type, something suitable is available in the UK from here - www.maplin.co.uk - part code is L51AY.

In the USA and Canada, the slug is shipped with a supply that only works with North American-style voltages (100-120V). Do NOT attempt to plug this in anywhere else. Mine (jp30) says (in the black part of the label) "Model No AD 5/2A", but below in the white part of the label "MODEL NO: M1-10S05". I have not opened up my supply, but judging by its size it is a switched mode design.

Outside North America, the slug is shipped with a universal switching power supply (100-240V). Tiersten reports that his UK NSLU2 is supplied with one labeled "Model No AD 5/2A" as well with "Model No: SA020507" below. There is a screw on the casing of this supply that allows the prong part of the unit to be removed and replaced with a country specific part. We do NOT recommend that anybody removes the screw or prongs as this will expose live contacts on the prong part once removed.

The newer style UK plug has a "Model No: of AD 5/2C", and "Model No: MU12-2050200-B2". (Will try and upload a picture later)

Simon reports that his UK slug was supplied with a power supply just as described above, ie. "Linksys AD 5/2A" but the model number was SA070507. It was 'Made in China' and is rated for 100-240V 50-60Hz. It has the screw and facility for different country adapters as described above. I don't know the age of the power supply since the Slug was purchased second-hand. It showed an interesting mode of failure.... after being used for about 1 year 24/7, the LED still illuminated and the unloaded votlage was 5.0V (good) but when a Slug was switched on, the voltage dropped to about 3V and the Slug could not boot. The Slug's Power LED showed faint 'pulsing' in time with USB Memory stick access attempts (difficult to see with your finger over the Power button though). The power supply was binned.

I had the exact same problem as Simon reports. I openened up the casing by putting it in a vice with the plug leads facing upwards, while supporting the sides of the upper half with small chop-sticks. This way the thing cracked open without damage. Inside was a 470uf 16Volt Electrolytic capacitor that looked overheated. After replacing it the supply worked fine again and so did the NSLU2. Glue the parts together or put a tie-wrap around the casing (as I did) and you're done.

I also followed the advice above and changed the Electrolytic Capacitor, a simple soldering job, mine exhibited a bulge on the top. After this the output voltage was stable at 5volt, off and on load. I had problems buying a 470uf 16Volt Electrolytic so instead used a 25Volt Capacitor, physically larger but there is room to fit. Also I noticed another slightly smaller Electrolytic directly across the output side that seemed slightly bulged, 100uf 25Volt, so changed this also.

For those countries that can handle the so called "Euro"-plug, the following power supply seems to be used (at least mine in Germany got shipped with it): I.T.E. Power Supply Model No "MU12-2050200-C5" Input: 100-240V~ 50/60Hz 0.5A Output: 5.0V = 2.0A the inner hole is the plus-lead, the outer ring is the minus-lead. Mine is glued together with no extra screw.

Note. I recently bought a 2.5mm-5.5mm DC supply and it does not work. The center pin is too big and won't fit. Not sure if there are different models, but I bought mine in the US around 2006. I'm going to try a 3mm supply.

If you have a power supply that doesn't match either of these designs, please add to this page.

My 120V Model M1-10S05 had a bad power diode (D7) in the output stage. An ohmmeter across the output terminal gave about 1.5 ohms in either direction. It is a 5A40V Schottky (SB540), Digikey part number SB540-E3/54GICT-ND, $0.51CDN. Replaced it and back in business.

A good replace power supply (at least available in the Netherlands) is the: Hape NV69 (http://www.hape.nl/site/?page=2&s=detail&qs=&c=4&p=6). It's a switching power supply which is capable of delivering 5VDC at 2.5A max. The primary supply may vary between 100-240VAC (50/60Hz). The supply comes with different (adapter) plugs of which one is NSLU2 compatible. Make sure to select the correct polarity (as described above). The polarity can be changed by rotating the plug. The supply is also capable of delivering output of 3, 4.5, (5,) 6, 6.5 and 7VDC.

I bought a Hape NV69MK2 (the one described above) but none of the plugs fit. On top of that, it died soon after.

Another replacement available is the MW Camplus Digital Camera Charger that works flawlessly and it's similar to the above Hape charger. Couldn't find any info on it on the internet, but it appears to be German built and it's available in Portugal at this link: (http://www.mauser.pt/catalog/product_info.php?cPath=23_66&products_id=26762). It provides 5V/2.5V and brings a compatible SLUG plug. Another workaround is the PSP (SONY Playstation Portable) compatible charger that will provide 5V/2A but need the end plug to be cut and replaced by a compatible one. This might be easier to find. I'll fix the original power supply, blown up 470uF 16V capacitor but right now I'm back to business. (Edit: Just replaced the blown 470uF capacitor for one 470uF 25V, and back to business. The power suply works again. Just a note: with the failed capacitor, the power led just flickered and didn't stay solid green).

Symptoms: Two LEDs? would flicker for a couple of seconds when the Slug was switched on, then disappear. If the network cable was detached, it would go through the normal cycle of LEDs? and remain on for about a minute, then switch off (obviously I could not observe what the slug was doing without a network connection!)

I bought one of these: http://www.maplin.co.uk/Module.aspx?ModuleNo=48908 because the one on special has doubled in price. It was effortless to fit and now my darling slug is back in business. I should also point out that the power supply failed during a very hot weekend.

view · edit · print · history · Last edited by Legrandin.
Based on work by Legrandin, Peter Brown, thx1011, fcarolo, Rene Vermijs, SDM485, RobHam, poppan, Bullfrog, Klaus Ruebsam, Rob, NigelS, Simon, Reedy Boy, quack, tman, Russ, and jp30.
Originally by jp30.
Page last modified on August 30, 2009, at 10:45 AM