NSLU2-Linux
view · edit · print · history

gastro.nslu2-linux.org

The Native Build Machine consists of a Linksys NSLU2 with Unslung 3.18 and the following packages:

  • autoconf 2.59-1
  • automake 1.9.4-2
  • bash 2.05b-3
  • bison 1.875-2
  • coreutils 5.2.1-4
  • crosstool 0.28-rc37-5
  • findutils 4.1.20-2
  • flex 2.5.4a-1
  • gawk 3.1.4-2
  • grep 2.4.2-3
  • groff 1.19.1-2
  • libtool 1.5.10-2
  • m4 1.4.1-1
  • make 3.80-1
  • patch 2.5.4-2
  • perl 5.8.6-2
  • pkgconfig 0.15.0-1
  • sed 4.1.4-1
  • tar 1.14-2
  • wget-ssl 1.9.1-1

There are other packages installed on the native build machine, but the ones listed above are the only packages that package developers should assume will be there. Native packages are often demoted because they assume some other package is installed, when in fact it needs to be explicitly staged first.

If you are a package developer, and would like to see some other package installed on the native build machine, please post your request, with a reason, in an email to the yahoo list; or contact one of the core developers on the #nslu2-linux irc channel.

Package Installation Details

1) Check for network connectivity to the package repository from the NSLU2 first: "ping ipkg.nslu2-linux.org"
- If this does not work, then please check the NSLU2 DNS settings in the web interface (under "Administration", "LAN").
2) Update the NSLU2 local list of available packages: "ipkg update"
3) Update the NSLU2 list of available feeds: "ipkg install unslung-feeds"
4) Update the list of available packages from new feeds: "ipkg update"
5) Check the list of available packages for ones that you want on your NSLU2: "ipkg list"
6) Install the packages: "ipkg install <package-name>"
7) You can install all the packages required for unslung development at once by: "ipkg install unslung-devel"
view · edit · print · history · Last edited by ka6sox.
Based on work by pTweeety, gduncan, and jp30.
Originally by dyoung.
Page last modified on May 26, 2006, at 07:21 AM