NSLU2-Linux
view · edit · print · history

Use the following procedure to build a newer version of thttpd web server. This same procudure can also be used build (cross-compile) other utilities.

There are problems with the Linksys supplied version of thttpd. For example, the default directory indexer brings up hard-coded cruft from the admin web page.

With a clean compile of version 2.25b you can index directories (that don't have index.htm files) without problems.

Note that thttpd supplied with snapgear is very old (version 2.04), and the version supplied with the NSLU2 is newer, but not the latest. Many other utilities in the snapgear 3.0.0 source are quite old. FYI.

How to compile thttpd:

  1. Compile the Linksys snapgear sources using the procedure described in the how-to section (http://www.nslu2-linux.org/wiki/HowTo/BuildSnapgearSources) of the NSLU2 wiki.
  2. Rename the directory user/thttpd to user/thttpd.2.04
  3. Download version 2.25b of thttpd from http://www.acme.com/software/thttpd/ I put the software in the same directory as the old version (e.g. user/thttpd).
  4. In the thttpd directory, type ./configure to create the Makefile. (Note: I did this in my native linux PC's environment, so there may be some problems.)
  5. To fix a compile error, comment out the line CC=gcc in the Makefile.
  6. Run make xconfig in the snapgear root directory and select the build of thttpd (not enabled by default)..
  7. Do a snapgear build. The build fails, after completing thttpd, but before doing any of the extra thttpd utilities (ssi, htpasswd, makeweb, etc.). If you want these utilities, you need to create Makefiles for them.
  8. Copy thttpd to your NSLU2 and test it.

Binary is at http://groups.yahoo.com/group/nslu2-linux/files/

view · edit · print · history · Last edited by Martin J Hsu.
Originally by michaelebrownmindspringcom.
Page last modified on July 31, 2005, at 04:39 PM