NSLU2-Linux
view · edit · print · history

DS101.SegfaultInIpkg History

Hide minor edits - Show changes to markup

January 04, 2008, at 08:18 PM by erikja -- What succeded here ws to mv the libpthread to .back whereafter the ipkg update worked out of the box.
March 12, 2007, at 08:13 PM by eriktar --
Changed lines 5-9 from:
 ipkg: /lib/ld-linux.so.2: version `GLIBC_2.1.1' not found (required by /opt/lib/libc.so.6)
 ipkg: /lib/ld-linux.so.2: version `GLIBC_2.2.3' not found (required by /opt/lib/libc.so.6)
 ipkg: /lib/ld-linux.so.2: version `GLIBC_2.2' not found (required by /opt/lib/libc.so.6)
to:
 ipkg: /lib/ld-linux.so.2: version `GLIBC_2.1.1' not found 
 (required by /opt/lib/libc.so.6)
 ipkg: /lib/ld-linux.so.2: version `GLIBC_2.2.3' not found 
 (required by /opt/lib/libc.so.6)
 ipkg: /lib/ld-linux.so.2: version `GLIBC_2.2' not found 
 (required by /opt/lib/libc.so.6)
Changed lines 36-37 from:
 wget: relocation error: /opt/lib/libpthread.so.0: symbol __libc_sigaction, version GLIBC_2.2 not defined in file libc.so.6 with link time reference
to:
 wget: relocation error: /opt/lib/libpthread.so.0: symbol __libc_sigaction, 
 version GLIBC_2.2 not defined in file libc.so.6 with link time reference
Changed lines 40-41 from:
 ipkg_download: ERROR: Command failed with return value 127: `wget --passive-ftp    -q -P /tmp/ipkg-cTs3V9  http://ipkg.nslu2-linux.org/feeds/optware/ds101/cross/stable/Packages.gz'
to:
 ipkg_download: ERROR: Command failed with return value 127: `wget --passive-ftp -q -P 
 /tmp/ipkg-cTs3V9  http://ipkg.nslu2-linux.org/feeds/optware/ds101/cross/stable/Packages.gz'
March 12, 2007, at 08:11 PM by eriktar --
Deleted line 4:

<snip>

Changed lines 15-18 from:

sh bootstrap.sh rm /opt/lib/libc*

to:
 sh bootstrap.sh
 rm /opt/lib/libc*
Changed lines 22-25 from:

ipkg install openssl.ipkg ipkg install wget-ssl.ipkg

to:
 ipkg install openssl.ipkg
 ipkg install wget-ssl.ipkg
Changed lines 29-40 from:

src/gz cross http://ipkg.nslu2-linux.org/feeds/optware/ds101/cross/stable

rm /opt/lib/libpthread* rm /opt/lib/libnss_files* ipkg update Downloading http://ipkg.nslu2-linux.org/feeds/optware/ds101/cross/stable/Packages.gz Inflating http://ipkg.nslu2-linux.org/feeds/optware/ds101/cross/stable/Packages.gz Updated list of available packages in /opt/var/lib/ipkg/cross Successfully terminated.

to:
 src/gz cross http://ipkg.nslu2-linux.org/feeds/optware/ds101/cross/stable

To verify that all now is well do a ipkg update. If this also ends in errors like this:

 Downloading http://ipkg.nslu2-linux.org/feeds/optware/ds101/cross/stable/Packages.gz
 wget: relocation error: /opt/lib/libpthread.so.0: symbol __libc_sigaction, version GLIBC_2.2 not defined in file libc.so.6 with link time reference
 An error ocurred, return value: 1.
 Collected errors:
 ipkg_download: ERROR: Command failed with return value 127: `wget --passive-ftp    -q -P /tmp/ipkg-cTs3V9  http://ipkg.nslu2-linux.org/feeds/optware/ds101/cross/stable/Packages.gz'

Try removing these files

 rm /opt/lib/libpthread*
 rm /opt/lib/libnss_files*

Retry the ipkg update command

 ipkg update
 Downloading http://ipkg.nslu2-linux.org/feeds/optware/ds101/cross/stable/Packages.gz
 Inflating http://ipkg.nslu2-linux.org/feeds/optware/ds101/cross/stable/Packages.gz
 Updated list of available packages in /opt/var/lib/ipkg/cross
 Successfully terminated.

If you get the Successfully terminated statement above your in the game. If not try and figure out what is wrong and update this guide if you do find out.

March 12, 2007, at 08:05 PM by eriktar --
Changed lines 4-9 from:

ipkg install openssl.ipk ipkg: /lib/ld-linux.so.2: version `GLIBC_2.1.1' not found (required by /opt/lib/libc.so.6) ipkg: /lib/ld-linux.so.2: version `GLIBC_2.2.3' not found (required by /opt/lib/libc.so.6) ipkg: /lib/ld-linux.so.2: version `GLIBC_2.2' not found (required by /opt/lib/libc.so.6)

to:
 ipkg install openssl.ipk

<snip>

 ipkg: /lib/ld-linux.so.2: version `GLIBC_2.1.1' not found (required by /opt/lib/libc.so.6)
 ipkg: /lib/ld-linux.so.2: version `GLIBC_2.2.3' not found (required by /opt/lib/libc.so.6)
 ipkg: /lib/ld-linux.so.2: version `GLIBC_2.2' not found (required by /opt/lib/libc.so.6)
March 12, 2007, at 08:03 PM by eriktar --
Added lines 1-40:

DS101-Linux For some the ipkg installation dont go to smoothly. If you get lines like the following you should try this guide.

ipkg install openssl.ipk ipkg: /lib/ld-linux.so.2: version `GLIBC_2.1.1' not found (required by /opt/lib/libc.so.6) ipkg: /lib/ld-linux.so.2: version `GLIBC_2.2.3' not found (required by /opt/lib/libc.so.6) ipkg: /lib/ld-linux.so.2: version `GLIBC_2.2' not found (required by /opt/lib/libc.so.6)

Issuing bootstrap.sh will fail at some point because of conflicting /opt/libc* files. Anyway, start the script and remove the libraries after the script has failed:

sh bootstrap.sh rm /opt/lib/libc*

Then install the other ipkg-files:

ipkg install openssl.ipkg ipkg install wget-ssl.ipkg

Finally create the file /opt/etc/ipkg/cross-feed.conf with the following contents (one line):

src/gz cross http://ipkg.nslu2-linux.org/feeds/optware/ds101/cross/stable

rm /opt/lib/libpthread* rm /opt/lib/libnss_files* ipkg update Downloading http://ipkg.nslu2-linux.org/feeds/optware/ds101/cross/stable/Packages.gz Inflating http://ipkg.nslu2-linux.org/feeds/optware/ds101/cross/stable/Packages.gz Updated list of available packages in /opt/var/lib/ipkg/cross Successfully terminated.

view · edit · print · history · Last edited by erikja.
Originally by eriktar.
Page last modified on January 04, 2008, at 08:18 PM